Upgrade issue

Have a question? Welcome here!
User avatar
jjeffman
Posts: 91
Joined: Thu Dec 08, 2011 1:05 pm
Location: Porto Alegre, Brazil

Upgrade issue

Postby jjeffman » Tue Dec 22, 2015 1:14 pm

Hello Artem,

I am facing a trouble after having done the steps which are defined on https://github.com/etraxis/etraxis-obso ... ng-eTraxis.

The previous version was 3.6.6 , so I have applied both mysql scripts for 3.6x to 3.7x and for 3.7x and 3.8x .

I have backed up the config.php file and I have replaced all folders and files of the old version by the ones which are in the "src" folder from the version 3.8.1 zip file.

Now I am getting a undefined class error : "Fatal error: Class 'XSLTProcessor' not found in E:\Webdesign\webserver\eTraxis\engine\xml.php on line 302".

I am using PHP 5.3.22 as module of Apache 2.2.22 . Should I upgrade PHP version ? My php version do not have the php_xsl.dll .

Thank you very much.
Best regards.

Jayme Jeffman

User avatar
Artem
eTraxis Support
Posts: 227
Joined: Mon Sep 15, 2008 2:51 am
Location: Auckland, New Zealand
Contact:

Re: Upgrade issue

Postby Artem » Thu Dec 24, 2015 5:19 am

Hello Jayme,

You have to enable the "php_xsl" extension. Strange you don't have it, it must be present in the "ext" directory of your PHP deployment.
Best regards,
Artem

User avatar
jjeffman
Posts: 91
Joined: Thu Dec 08, 2011 1:05 pm
Location: Porto Alegre, Brazil

Re: Upgrade issue

Postby jjeffman » Thu Dec 24, 2015 12:33 pm

Thank you very much for answering me.

I have run the PHP installation software and I have added the XSL extension, that solved the problem.

Thank you very much.
Best regards.

Jayme Jeffman


Who is online

Users browsing this forum: No registered users and 1 guest